✓ Solved

Failed to mount /dev/sda as root file system.

What's going on?, this is new, first boot, I've tried in Dallas and Atlanta, I was able to fix it by Booting in Rescue mode then running fsck, but the problem sometimes still shows up after restart, seems unstable, really frustrating. <img alt="Alt text" src="https://i.ibb.co/GvHCYHf/Screen-Shot-2022-03-24-at-19-34-01.png">

3 Replies

✓ Best Answer

@optimalwp is your Linode booting with Grub 2 by chance? We've been seeing reports of some Linodes have issues booting normally with Grub 2 – it seems to be related to an issue with the kernel scanning for SCSI devices asynchronously:

[    2.022709] sd 1:0:1:2: [sda] 1056768 512-byte logical blocks: (541 MB/516 MiB)
[    2.023789] sd 1:0:1:2: [sda] Write Protect is off
[    2.025452] sd 1:0:1:2: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    2.027243] sd 0:0:0:0: [sdb] 103817216 512-byte logical blocks: (53.2 GB/49.5 GiB)
[    2.028190] sd 0:0:0:0: [sdb] Write Protect is off
[    2.031940] sd 0:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    2.084375] sd 1:0:1:2: [sda] Attached SCSI disk
[    2.100267] sd 0:0:0:0: [sdb] Attached SCSI disk
mount: mounting /dev/sda on /root failed: No such device
Failed to mount /dev/sda as root file system.
(initramfs) [ 1723.420936] sd 1:0:1:2: [sda] Synchronizing SCSI cache
[ 1723.421704] sd 0:0:0

The easiest solution is going to be just switching to the Linode kernel:

https://www.linode.com/docs/guides/managing-the-kernel-on-a-linode/#updating-the-linode-kernel

Try selecting "Latest 64-bit" and rebooting, that should resolve the issue.

If you want to keep using Grub and the distro kernel, you'll need to modify your grub config (/etc/default/grub) by appending scsi_mod.scan=sync to the GRUB_CMDLINE_LINUX line, like so:

GRUB_CMDLINE_LINUX="console=ttyS0,19200n8 net.ifnames=0 scsi_mod.scan=sync"

Sorry like I said before, it's on the first boot after it's created, so maybe its the default setting?

@optimalwp yes understood – most of our distros deploy using Grub 2 by default, not the Linode kernel.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct