linode-cli freezes on initial config

I'm running debian 10 in WSL2.

I installed linode-cli and boto via pip3 per instructions. I typed linode-cli config and I see:

$ linode-cli config
Welcome to the Linode CLI.  This will walk you through some initial setup.

And it just hangs there forever.

What can I do to troubleshoot?

1 Reply

This may be related to the interactive setup that's used by default with Linode CLI. Running linode-cli configure on its own will prompt a web browser to open so you can log into the Cloud Manager to authenticate. If you're using WSL2, there is no browser to open, which is why the command is hanging. Instead, you can use the token-based configuration by running linode-cli configure --token to provide your API token and select options for preferred defaults. More info about using the non-web-based method can be found here.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct