My domain seems to be not linked to the linode server?


I had a running linode server for a specific domain (it was a wordpress instance). I had my DNS sorted and it was fine. The domain was pointing to the server.

Later I decided to change from the wordpress instance to an Ubuntu server. I deleted the instance and then a created a new one with Ubuntu 20.04 LTS.

I had my domain name still in place and all I needed to do is change the AAAA records. I changed the records with the new IP address of the Ubuntu server, but nothing happens. Not after one hour, 3 or even a day.

Am I doing something wrong? I've got another domain which works just fine and I used the same strategy.


2 Replies

You are correct that updating your DNS A/AAAA records to point to your new Linode server IPs should work as you expected.

Often when troubleshooting this kind of issue we find that folks are suffering from things like cached records with long TTLs, static entries in /etc/hosts, or problems with a local resolver.

What sort of output do you get from dig +trace $domain? Are the name servers being contacted the ones you expect? Are you receiving the correct IP?

What happens if you try forcing a dig request to use a different resolver? For example: dig AAAA $domain @ to use Google's public resolver.

With that said: Having the privilege of visibility into your account details, I suspect that the issue may be related to the configuration of your new Linode. Are you certain that your web server is running?

I'm seeing a new server that has ports 80 and 443 closed but other common ports filtered, which leads me to believe you may have transferred your website over but forgot to start/enable the service.

I've just tried to delete the linode server and create a new one with a Wordpress. The domain was linked to the server in about 5 minutes time. I then deleted that again and created a new one, but with an Ubuntu 20.04 and installed NGINX. The IP returns the default page for NGINX, which means it works.

I've updated the AAAA records again now to point this new Ubuntu server, but nothing happens. Basically by IP it works, but by the domain name it doesn't. It tells: "The site cannot be reached.", classic…

I've looked into error.log file at /var/log/nginx and it literally shows no errors whatsoever.

I suspect it should be something to do with the config file for NGINX, should I point the server_name to the domain name? However, I did that before and it didn't really help.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct