After an apt update and reboot, I cannot access my server (Solved)

I'm running Ubuntu 22.04. I did an upgrade and reboot and suddenly I can't access my server. I can access the server via lish, but cannot access anything outside the server.

Here are my observations:

  • Pinging the server IP I get no response
  • Pinging (from the server to responds with Temporary failure in name resolution
  • tracert (from my PC) gets me as far as
  • oddly enough ufw is apparently no longer installed
  • sudo iptables-save gives me the following
# Generated by iptables-save v1.8.7 on Thu Nov 17 23:34:47 2022 
:INPUT ACCEPT [443961:45159848]
:OUTPUT ACCEPT [443627:45128416]
# Completed on Thu Nov 17 23:34:47 2022
  • sudo service sshd status shows me that it is running
  • I can ssh myuser@localhost but not to the ip address of a different linode.
  • route -n shows no records
  • /etc/netplan/01-netcfg.yaml shows:
  version: 2
  renderer: networkd 
      dhcp4: yes
  • Auto-Configure Networking is enabled

It would seem that my network isn't configured correctly after the update.
Please advise.

-- Solved: The problem was the systemd-networkd service had been disabled. Starting it fixed everything.

1 Reply

Glad to see you got this resolved and thank you for updating this post with the solution. I've seen this happen to other customers who have run into the same issue when performing an inline upgrade like this. It's almost always networkd.

Here's a link to Ubuntu's networking doc that can help with this: Network - Configuration | Ubuntu


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct