New DNS records are not showing up

I've added a new A record and two CNAME records to my domain. It's been 48 hours and the records are still not showing up with nslookup. I've set the TTL to 5 minutes with no results. Am I missing something, or do I just need to be more patient?

9 Replies

I suspect you just have to be more patient… What's the domain?

nslookup has been deprecated for at least 20 years and hasn't been actively maintained for probably even longer (at least on Linux anyway). See:

Note the date on the link… 2001! The fact that nslookup doing the wrong thing is not surprising. Use dig instead.

I believe M$ ships an nslookup command for Windoze that is a work-alike of the original for Unixen (I suppose the work-alike is maintained but, given M$'s unique notion of "support", that fact would be a Redmond state secret).

-- sw

Okay, I'll try to be more patient, but it has been three days now and that seems like an exceptionally long time to wait. I manage DNS at work and domain changes normally take a few minutes to propagate.

BTW, there's nothing wrong with nslookup. There were plans to deprecate it back around 2001, but that decision was reversed, and it was been fully supported by ISC since 2004, beginning with BIND 9.3. All the Linux systems I manage (which are all current) support nslookup, host, and dig, and I use all three interchangeably depending on the data I need. All three services show that my new DNS records have still not propagated.

This sounds like a problem that’s worthy of a support ticket.

— sw

Where are the DNS records being set? At your registry (which is what I do) or on Linode's DNS system?

What is the URL?

What registry are you using?


Doh! I'm an idiot. I was trying to set the DNS records on Linode's DNS page instead of at the registry where the domain is actually registered. Thanks for the reminder. I've made the entries at the registry and they propagated right away. All is well now.

But that does raise the question: Why can I edit DNS records within Linode if my domain isn't registered there? Does Linode serve as a DNS registry?

Linode runs nameservers. I have my domains registered at Namecheap, but I tell Namecheap to use Linode as the name server for those domains because I prefer the control that gives me (for example, I can use the Linode API to set DNS records for when I need to update my TLS certificates at Let’s Encrypt)

Thanks for the tip. That sounds like a good idea.

I have the same situation as @procyon…except I use GoDaddy.

-- sw

Why can I edit DNS records within Linode if my domain isn't registered there? Does Linode serve as a DNS registry?

Linode lets you do what you want with respect to DNS records in their infrastructure. If you don't point your domain in your registry to their Linode nameservers nothing is going to happen.

I like to use my registry to enter DNS records. THAT is their core business and if something goes wrong they know how to fix it… because that is what YOU are paying them for. Also I've found that when you make changes to DNS at the registry they often propagates faster then making changes on the host's nameserver.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct