Hi, I am new to Linode, but have 3 years experience on aws. Everytime I launch a Linode, it's inaccessible. Most of the time I tried cPanel instance. But no hope. Could not do it from Firewall section. Tried install ubuntu/centos everything. But IPTables, Firewalld, UFW… no hope! When I launch a server, ip is not directly accessible. why? On each of the youtube videos I watched for the solution, every instance is loading on direct ip right away! What am I doing wrong here?

It's been around 23 hours without any response on the support ticket. Please help.

10 Replies

Are you saying you cannot SSH into your server?

Can you log in with LISH Console?

Call Linode support directly.

Cannot SSH, cannot visit any cPanel/WHM port or even the IP. May be firewall issue. But totally stuck for sure. Opened a ticket.

Opened a ticket.

Forget the tix. Call them directly.

Maybe something from here will help:

Lots of support here for that error:

What is the IP. Let us try it?

Sure! Here is the IP:

Your system is alive…I can ping it. This could be a DNS issue… If you haven't set up DNS for your Linode, you need to do that. Linode does not do it for you.

However, since the IP address is inaccessible, I'm pretty sure this is a firewall issue.

You never said if you can log in at the lish console… You need to do that and open ports 22/tcp (ssh), 80/tcp (http), 443/tcp (https), 53/udp (dns), 53/tcp (dns) in your firewall.

After you do that, you need to set up ssh key authentication properly.

-- sw

Thank You! I can access LISH for sure. It is a cpanel instance over centos 7. I can ping the ip as well. The only problem while I visit it on the browser. So, after login to lish, in which firewall service should I open these ports? Firewalld? IPTables?
Thanks in Advance

If you know how to configure iptables/iptables6 I would do that & turn off firewalld.

If not, configure firewalld.

firewalld is like Ubuntu’s ufw…a “friendly front-end” to iptables so the ultimate configuration ends up doing the same thing.

— sw

Oh, thanks again. I didn't know that. But even after opening ports with firewalld and running: > firewall-cmd --reload
it's still not working. Don't understand why!

Did you call Linode support?

I was able to connect to the IP address you gave a few minutes ago:

stevewi:~ $ ssh
The authenticity of host ' (' can't be established.
ED25519 key fingerprint is SHA256:NOQ0wn+m1GMRWBGlH59ffSVNd5ZxRJewWTe0m0/g5/I.
This key is not known by any other names
Are you sure you want to continue connecting (yes/no/[fingerprint])? y
Please type 'yes', 'no' or the fingerprint: yes
Warning: Permanently added '' (ED25519) to the list of known hosts.
stevewi@'s password: 

So, perhaps you should pursue getting this working and then you can figure out what's wrong with your web server. I suspect it's mis-configured (or not running):

stevewi:~ $ telnet 80
telnet: connect to address Connection refused
telnet: Unable to connect to remote host
stevewi:~ $ telnet 443
telnet: connect to address Connection refused
telnet: Unable to connect to remote host

-- sw


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct