Vaultwarden: Browser give "ERR_TOO_MANY_REDIRECTS" on initial access to website

(Apologize for not learning markdown. I tried here but failed.)

I am following this procedure (takes you to the failure point):

I did have to (for now!) disable the server firewall because I haven't yet figured out everything it needs. My client firewall is not blocking anything.

Here is /etc/Caddyfile: {
encode gzip

# The negotiation endpoint is also proxied to Rocket
reverse_proxy /notifications/hub/negotiate

# Notifications redirected to the websockets server
reverse_proxy /notifications/hub

# Send all other traffic to the regular Vaultwarden endpoint

Here is the end of the caddy log:

{"level":"info","ts":1679098503.2627814,"logger":"http","msg":"waiting on internal rate limiter","identifiers":[""],"ca":"","account":""}
{"level":"info","ts":1679098503.2629685,"logger":"http","msg":"done waiting on internal rate limiter","identifiers":[""],"ca":"","account":""}
{"level":"info","ts":1679098503.5212197,"logger":"http.acme_client","msg":"trying to solve challenge","identifier":"","challenge_type":"http-01","ca":""}
{"level":"info","ts":1679098503.716019,"logger":"http","msg":"served key authentication","identifier":"","challenge":"http-01","remote":"","distributed":false}
{"level":"info","ts":1679098503.7773952,"logger":"http","msg":"served key authentication","identifier":"","challenge":"http-01","remote":"","distributed":false}
{"level":"info","ts":1679098503.82911,"logger":"http","msg":"served key authentication","identifier":"","challenge":"http-01","remote":"","distributed":false}
{"level":"info","ts":1679098504.1677046,"logger":"http.acme_client","msg":"authorization finalized","identifier":"","authz_status":"valid"}
{"level":"info","ts":1679098504.1678681,"logger":"http.acme_client","msg":"validations succeeded; finalizing order","order":""}
{"level":"info","ts":1679098504.994031,"logger":"http.acme_client","msg":"successfully downloaded available certificate chains","count":2,"first_url":""}
{"level":"info","ts":1679098504.9946651,"logger":"tls.obtain","msg":"certificate obtained successfully","identifier":""}
{"level":"info","ts":1679098504.9947495,"logger":"tls.obtain","msg":"releasing lock","identifier":""}

Here is the entirety of the Vaultwarden log:

| Starting Vaultwarden |
| Version 1.27.0 |
| This is an unofficial Bitwarden implementation, DO NOT use the |
| official channels to report bugs/features, regardless of client. |
| Send usage/configuration questions or feature requests to: |
| |
| Report suspected bugs/issues in the software itself at: |
| |

[INFO] No .env file found.

[2023-03-18 00:08:57.733][vaultwarden][INFO] Private key created correctly.
[2023-03-18 00:08:57.735][vaultwarden][INFO] Public key created correctly.
[2023-03-18 00:08:58.054][vaultwarden::api::notifications][INFO] Starting WebSockets server on
[2023-03-18 00:08:58.056][start][INFO] Rocket has launched from

Nothing that indicates there is anything wrong.

I tried stopping file2ban, but that didn't help.

I tried using the RDNS address but got the same error.

Pings all around work fine. I thought there was a DNS problem since I recently changed the IPv4 address and added the IPv6 address in

I tried allowing redirects in the browser. No luck.

Does anyone have any ideas why I might be getting this error?

Thanks. :)

2 Replies

Does anyone have any ideas why I might be getting this error?

You're assuming that everybody in the Linode-world knows what this "vaultwarden" thing is.

Au contraire…

Given that this is the first time I've ever heard the two words "vault" and "warden" concatenated into a name (and I'm probably way older than you), you're going to have to ask your question about stuff we understand -- web servers, Kubernetes clusters, etc.

I'd suggest doing simple stuff first:

If that doesn't work, try asking your question regarding items that the group here understands.

-- sw

Ok then. I'll just go away.

The linked info didn't help.

And, how am I supposed to know what anyone understands?

I did start out by linking to the Linode Procedure to assist in your understanding.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct