"port 22: Connection timed out"

@isackey and @eruzanski

Hope you are doing well enough today .

When I run ssh -L 61000:localhost:5901 -N -l …… This command from my local computer Its saying - " ssh: connect to host 172.105……. port 22: Connection timed out " .

First time I created kali linux and I was able to connect with my local computer but could not connect with VNC It was saying your "computer Is refusing to connect" .

Then I deleted kali linux linode . Today again I set up kali linux linode but could not connect with my local computer Its saying "ssh: connect to host 172.105……. port 22: Connection timed out" .

Please I need your assistance how to resolve this Issue direct me .

Thanks a bunch In advance

2 Replies

We have a similar recent post about this issue that you can check out here.

I wanted to add one thing to the response in that post. I ran through the process described in our Marketplace App Guide just now and I was able to connect without running into the exact issue you're seeing. I used RealVNC Viewer because it was easy to install.

While I didn't get the exact error you're seeing, I did experience some hanging while running the command you mentioned from my local computer. On our documentation, it says to run the command like this:

ssh -L 61000:localhost:5901 -N -l [username] [ip]

The console output from my terminal used this syntax (I used fake numbers for the IP so you could see what it would look like):

 ssh -L 61000:localhost:5901 -N -l cassandra 111-222-333-444.ip.linodeusercontent.com 

I changed the syntax to match the guide and ran this:

ssh -L 61000:localhost:5901 -N -l cassandra 111.222.333.444

I'd recommend trying to use the ip as the host name instead of the domain provided by the console output and see if that helps.

Otherwise, you may want to look into standard troubleshooting steps like checking your firewall settings or checking the connection between your local machine and your server with MTR.


Thanks a ton for your reply .
I tried this format ( You recommend ) " ssh -L 61000:localhost:5901 -N -l cassandra 111.222.333.444 "

After that the Issue Is not resolved .

What I did to resolve this Issue Include -

1 - I deleted my previous kali Linode and create new one .

2 - I ran MTR report there Is no loss .I ran MTR report only on linode and could not run on my local machine . Should I run on local machine also ? Because I am facing some kind of problem to run MTR report on my windows local machine .

3 - I created cloud firewall and enabled . Preset - SSH , Protocol - TCP , Port range - 22 , Sources - ALL , Action - Accept .

I added only Inbound rule not outbound rule .

Still I have "port 22: Connection timed out"

What should I do ?

Please advice me ( with link ) on this Issue how to resolve .


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct