Can't view Wordpress setup form when I type IP address in to browser.

I want to create a Wordpress website on linode, so I followed these directions to Install WordPress with Docker Compose:

However, when I get to Step 4 and visit my Linode's IP address in my web browser, I am not directed to the Wordpress setup form. It just says "This site can't be reached".

To fix it I tried adding inbound and outbound Firewall Rules for port 80 and port 443. Everything else in the process seemed to go smoothly. Why can't I see the Wordpress setup form when I put in my IP address? Is there a step missing in the instructions?

3 Replies

I just ran through the guide you shared and I ended up with the same error at first. What fixed it for me was making changes to my command based on the note provided at the top of the guide.

It explains that using the Docker Compose plugin, which is what I did using those instructions, require replacing the hyphen with a space in commands, which would affect step 3 here.

So, instead of running what the guide says:

docker-compose up -d

I ran the plug-in version:

docker compose up -d

This brought my site up and I was able to see my admin page within a minute or two.

I did this as root because I intend to delete this instance now. You'll likely want to set up a non-root user with permissions to use Docker before running that command.

If that doesn't work, I'd recommend checking out Docker's official documentation for more help.

Finally, I'd recommend undoing any changes you made to the firewalls until you can resolve the original issue just to remove one possible layer of possible complication. You can then go through our guide to securing your server, which includes a section on configuring firewalls.

Thank you for the reply! Unfortunately I have not been able to get it to work. The docker container seems to start just fine. At least I get this message:

[+] Running 3/3
✔ Network my_wordpress_default Created 0.1s
✔ Container my_wordpress-db-1 Started 0.4s
✔ Container my_wordpress-wordpress-1 Started

I deleted my firewall and tried stopping and starting docker several times. I also tried several suggestions from the docker website and stack overflow, but I am unable to get the wordpress login site to load. I also tried uninstalling and reinstalling docker.

I think I may just try another method.

Why use Docker? WordPress is an easy install that is already 99% self-contained in that it uses standard most of the standard modules of PHP that are provided with a typical LAMP install. and the few other ones it needs are simple to install.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct