Connect a Linode Ubuntu VM using Guacamole

I created a Guacamole VM and an Ubuntu VM. I can SSH into the Ubuntu VM using Guacamole, but I cannot start a VNC session on the Ubuntu VM using Guacamole. Has anyone done this (I have to bet many have)? I tried both the TRiget and Tight VNC servers as well as multiple GUIs on the Ubuntu VM.

3 Replies

Maybe I'm wrong, but the way I'm understanding your set up here is that you have two separate Linodes. One of them has Guacamole installed on it, while the other one does not.
If that's accurate, then I think you'll need to install Guacamole on the Linode that it hasn't been installed on yet. Our How to Install Apache Guacamole on Ubuntu and Debian | Linode Docs guide should do the trick for that.

Some context around my thinking here: Guacamole is a service you can install on a Linux server, whereas Ubuntu is an operating system. Knowing that we have a Marketplace App for Guacamole, I am making an assumption that the Marketplace App was used to set up a Linode with Guacamole on it and another Linode was created with our Ubuntu image, which is just the base operating system.

If I'm misunderstanding the set up, it would be helpful to know more specifics about what you're trying to do.

My understanding was that as long as I ran a VNC server (like Tiger or Tight) on the target VM and had it listening on port 5901 then Guacamole could VNC in. I am able to SSH in using Guacamole this way. Are you saying I need Guacamole on both ends of the connection?


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct