Issue with rDNS

So currently I am trying to run a mail server on my linode. I have two IP addresses and when I try to send mail to gmail it blocks it because the SPF isn't set up correctly. Linode is apparently sending my mail through IPv6, however my server is only set up for IPv4. Can I force this in anyway or is there a way for me to set this up better? Thank you!

2 Replies

If you are having issues with your SPF records, if you have not already you may want to look over Linode's documentation on SPF records, here:

As far as rDNS is concerned, there is documentation on how to configure/set that specifically for IPv6 here:

Just in case you were interested, it looks like users on our community site have encountered similar issues in the past, and there was some good discussion on their setup and solutions here:

I hope that helps!


One additional thing to consider when it comes to mail and IPv6 is that the SLAAC addresses assigned to Linodes are all within the same range, and unfortunately, that means paying the price for any bad actors that have ever sent email from their Linodes.

The common workaround for this is to add an IPv6 routed range to your Linode, and configure your email to use and address from that range rather than your SLAAC address. This is even recommended by Spamhaus.

What I did for my own mail server was add a post-routing rule by following the suggestion in this Community Question. Once you've done this, you'll want to also set rDNS for the address you added from the range, and update your mail server settings accordingly.

Lastly, when it comes to running your own mail server, keep in mind that each mail provider has it's own quirks. I'd highly recommend reading this post about understanding mail deliverability to improve your success rates.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct