How to SSH correctly into Linode using Ubuntu linux.

I am getting the following error message when I try to ssh into my linode, but only when I am using a Ubuntu linux command line. I have no problem using Command Prompt or Windows PowerShell in Windows 10:
"Could not resolve hostname Temporary failure in name resolution"
Can anyone suggest possible reasons for this? After trying to resolve the problem for a couple of days now, I am completely at a loss to know what to try next!

1 Reply

I have a few troubleshooting ideas/recommendations, depending on how this issue is manifesting.

Are you trying to connect via LISH?. If so, you may want to try using Weblish, or SSH with the -vvv flag to help locate where the issue is.

Some additional troubleshooting guides on this topic can be found here:

After this, I would also recommend running an apt update && apt upgrade command, because sometimes simple stuff like that can fix an issue like this.

Just to be sure there was not a larger underlying issue, I deployed a test server in London just now and connected using LISH console via SSH and did not run into any issues.

Hope this helps!



Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct