DNS resolving problem ONLY on my Linode

I just can't figure this out. My Linode (Debian Lenny) can't resolve the IP address for gateway.securenet.com:

zero:~$ dig gateway.securenet.com A

; <<>> DiG 9.5.1-P2 <<>> gateway.securenet.com A
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 61640
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;gateway.securenet.com.        IN  A

;; Query time: 0 msec
;; WHEN: Fri Jul 10 04:31:24 2009
;; MSG SIZE  rcvd: 39

If I try the same dig command from my local workstation (or from any other server I can access) gateway.securenet.com resolves to

I've added gateway.securenet.com to /etc/hosts as a temporary fix, but if the IP changes it will disable online ordering for a client's website. This issue has been going on for a few days now. Any hints appreciated.

1 Reply

;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 61640

Hmm. is the DNS server you're using. Hmm, that's resolver1.fremont.linode.com

I get the same result if I request info from that DNS server.

% nslookup -type=ns securenet.com

** server can't find securenet.com: SERVFAIL

But I get good responses if I ask he.net's server (

Sounds like the linode provided DNS server doesn't like securenet.com :-)


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct