I just got the message - "Your computer or network may be sending automated queries." What should I do?

Linode Staff

When I'm using my Linode as a proxy and trying to get on Google Scholar, it says "We're sorry, but your computer or network may be sending automated queries. To protect our users, we can't process your request right now." I'm not running any program on my Linode that may send automated queries to Google. How do I solve this problem?

2 Replies

This is not an issue we see frequently but it seems as though there are lots of people online who have dealt with the same issue. Here is Google’s guidance on the matter:


The few customers in the past have been successful in resolving this issue but adjusting their ipv6 configuration. Perhaps these steps could be helpful:

a. Please run Google Search for “What is my IP”. If it returns as ipv6, you might have to force it to ipv4. You can find out how to force ipv4 resolution here:


b. Customers have also edited their ipv6 entry in their /etc/hosts/ file to add the following:

2607:f8b0:4005:801::200e google.com
2607:f8b0:4005:801::200e www.google.com
2607:f8b0:4007:805::100f scholar.google.cn
2607:f8b0:4007:805::100f scholar.google.com
2607:f8b0:4007:805::100f scholar.google.com.hk
2607:f8b0:4007:805::100f scholar.l.google.com

This solution has worked for them as well.

I just enabled ipv6 on my linode and noticed the same issue when getting Youtube RSS feeds. Simply testing
curl -4 https://www.youtube.com/feeds/videos.xml?user=chilledsanity
curl -6 https://www.youtube.com/feeds/videos.xml?user=chilledsanity

I did resolve this by throwing a ipv4 address for www.youtube.com in my /etc/hosts: www.youtube.com


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct