Issues with apache2 starting.

I've followed the directions at … 0.04-lucid"> through "Install and Configure the Apache Web Server".

But, when I go to start apache2 using "/etc/init.d/apache2 start," the follow is displayed:

  • Starting web server apache2


What could be the issue here?

7 Replies

I just uninstall apache2 using "apt-get purge apache2". Then I installed it again. Something that might be useful, this showed up during the install:

Setting up apache2-mpm-worker (2.2.14-5ubuntu8.4) …

  • Starting web server apache2


invoke-rc.d: initscript apache2, action "start" failed.

Is there any relevant information in /var/log/apache2/error.log or similar?

Yes, I finally figured to check the error.log file. The issue was with a virtual host file that I setup incorrectly.

I deleted it and disabled the site… things are working now.


This is likely an issue with your virtual hosts configuration file.

Most likely under /etc/apache2/sites-available/ if you followed the linode tutorial.

Check that everything is correct in the file. I had this issue where I had ~/public/logs/ in the config file but only had a directory ~/public/log/

Not the most helpful error when you just get [fail] …

Or you could read the last post and discover that the issue was fixed.


Let me guess, you always played a cleric in your AD&D games right?

//way to resurrect a year old thread//

Funky virtualhost debug command:

sudo apachectl -t -D DUMP_VHOSTS

PS didn't realise this was an old thread, sorry.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct