SFTP Jails stopped working


I followed Limiting Access with SFTP Jails on Debian and Ubuntu and made it work. Used to work for months. But now it stopped. Not sure if it could be somehow related to the linode restart that happened a week ago.

I checked all the settings but cannot find any reason why it shouldn't work.

Filezilla is giving me an error

Connection attempt failed with "ECONNREFUSED - Connection refused by server"
  • password is 100% correct.

  • I restarted sshd

  • tried to connect using ftpes protocol (FTP over explicit TLS) as a user that is not jailed with the same result

Any idea how I can make it work again?

Thank you


2 Replies

Sounds like you have Filezilla set to FTPS instead of SFTP.

SFTP is SSH File Transfer Protocol. It's handled by SSH server, and is totally different from old FTP.

FTPS is the old FTP in SSL/TLS tunnel, and is handled by a FTP server. You probably don't want to use it.

If you can SSH in, you surely can SFTP in; or at least, it wouldn't give you ECONNREFUSED.

If you can't SSH in, disregard all of the above, you have SSH bound to wrong interface or bad firewall rules.

> chroot directory must be root owned

is the answer. Not sure how this happened but all sorted out.

I do changed the ownership because wordpress needs be an owner if writing files but I am sure that I tested sft afterward..


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct