Fine tuning my MySQL with instructions from Linode library..

Hi friends,

I'm trying to follow the instructions here … networking">

to fine tune my linode.

I have been able to do the HTTP part, but I am having issues with the MySQL part.

Firstly, My my.cnf is in /etc/ folder and not /etc/mysql/my.cnf like the linode library article says.

Then my my.cnf contains only the following:

# Disabling symbolic-links is recommended to prevent assorted security risks


and nothing like

> key_buffer = 16K

maxallowedpacket = 1M

thread_stack = 64K

table_cache = 4

sort_buffer = 64K

netbufferlength = 2K

as the tutorials say.

How then can I fine tune my MySQL with to these settings?


2 Replies

I'm guessing you're running centos and the docs assume ubuntu

anyway, if a setting is missing from the config, it uses the default.

What I would do is to let the db run for a few days, then download and run

I installed mysql tuner and I got this

Variables to adjust:

*** MySQL's maximum memory usage is dangerously high ***

*** Add RAM before increasing MySQL buffer variables ***

querycachesize (> 60M)

table_cache (> 64)

innodbbufferpool_size (>= 69M)

So I entered /etc/mysql/my.cnf file but not sure what to adjust, what is this > saying to me? and where is mysql max memory usage defined, not one variables but all of these?

these is what i see in my.cnf

key_buffer = 300M

sortbuffersize = 4M

readbuffersize = 4M

readrndbuffer_size = 4M

myisamsortbuffer_size = 20M

querycachesize = 60M

this inno_db part I done even have? some guidance please.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct