Yet another question about Wordpress file permission

Hi all,

I installed a wordpress site on my newly installed Linode. It's ubuntu 10.4 LTS, Apache2.

When I was testing the wordpress posting, the editor didn't allow me to upload and embed an image. I checked the file permission of the wp-content/uploads folder. It's 755. Just to test, I changed that to 777 to allow WP to create ~/uploads/x folders then changed back the permission to 755. After this it is uploading images from the editor.

But I have a feeling that it may not be the permanent solution. As, when this month will end, WP will try to create a new ~uploads/10 and sever will not allow WP to do that(currently it's ~uploads/9 because I selected "Organize my uploads into month- and year-based folders" on WP options)

So I would really appreciate if anyone could tell me the permanent solution without compromising the security issue?


1 Reply


Got the solution from the Linode IRC.

Run this command from ssh

> sudo chown -R www-data:www-data /home/user/public/

or where ever your image folder is


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct