Problem with php timeout limit

I have large mysql database about 130 mb, I need to upload it through phpmyadmin, but I get error message

Script timeout passed

I already changed uploadmaxfilesize, memorylimit and postmaxsize in php.ini and also Maximum execution time setting maxexecutiontime = 30000 but it looks like this is not working because after 5 or 10 minutes I get this script timeout error message. How could that be if I changed maxexecution_time = 30000 which should be 500 minutes ?

And yes I restarted Apache after these changes :)

PS. I'm on local server, using xampp, but when I find out what is the problem, I will need to do all this on my Linode

3 Replies

It looks like PHPMyAdmin has its own config parameter for the timeout that overrides the PHP one.

See here:

Have you tried changing that one?

You should avoid doing large uploads like this via phpmyadmin, it can cause issues (such as this one). It's better to do it via the command prompt, using the mysql client.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct