I've just configured a new linode, and I'm having trouble with the IPv6 access.

ifconfig shows that it has an IPv6 address, but it appears that packets are getting lost somewhere as I can't access any ipv6 resources.

e.g. ping6 ipv6.google.com reports 100% packet loss

My other linode in the same data centre works fine.

Any ideas?

8 Replies

Have you configured your IPv6 address?

https://www.linode.com/docs/networking/ … networking">https://www.linode.com/docs/networking/native-ipv6-networking

Yes. The linode has an ipv6 address in the linode manager, and ifconfig shows this IP address.

Here are the commands you want to run:

ip -6 addr
ip -6 route

Those results will likely shed some light on this.

  • Les

root@vega:~# ip -6 addr
1: lo: up>mtu 65536 inet6 ::1/128 scope host validlft forever preferredlft forever 2: eth0: up>mtu 1500 qlen 1000
inet6 2a01:7e00::9503:ca45:d005:d13/64 scope global temporary dynamic
validlft 586473sec preferredlft 67473sec
inet6 2a01:7e00::f03c:91ff:fe89:da45/64 scope global dynamic
validlft 2591992sec preferredlft 604792sec
inet6 fe80::f03c:91ff:fe89:da45/64 scope link
validlft forever preferredlft forever
root@vega:~# ip -6 route
2a01:7e00::/64 dev eth0 proto kernel metric 256 expires 2591991sec
fe80::/64 dev eth0 proto kernel metric 256
default via fe80::1 dev eth0 proto ra metric 1024 expires 81sec
root@vega:~# ip6tables-save

Generated by ip6tables-save v1.4.21 on Thu Dec 4 14:51:31 2014

:ufw6-after-forward - [0:0]
:ufw6-after-input - [0:0]
:ufw6-after-logging-forward - [0:0]
:ufw6-after-logging-input - [0:0]
:ufw6-after-logging-output - [0:0]
:ufw6-after-output - [0:0]
:ufw6-before-forward - [0:0]
:ufw6-before-input - [0:0]
:ufw6-before-logging-forward - [0:0]
:ufw6-before-logging-input - [0:0]
:ufw6-before-logging-output - [0:0]
:ufw6-before-output - [0:0]
:ufw6-reject-forward - [0:0]
:ufw6-reject-input - [0:0]
:ufw6-reject-output - [0:0]
:ufw6-track-forward - [0:0]
:ufw6-track-input - [0:0]
:ufw6-track-output - [0:0]
-A INPUT -j ufw6-before-logging-input
-A INPUT -j ufw6-before-input
-A INPUT -j ufw6-after-input
-A INPUT -j ufw6-after-logging-input
-A INPUT -j ufw6-reject-input
-A INPUT -j ufw6-track-input
-A FORWARD -j ufw6-before-logging-forward
-A FORWARD -j ufw6-before-forward
-A FORWARD -j ufw6-after-forward
-A FORWARD -j ufw6-after-logging-forward
-A FORWARD -j ufw6-reject-forward
-A FORWARD -j ufw6-track-forward
-A OUTPUT -j ufw6-before-logging-output
-A OUTPUT -j ufw6-before-output
-A OUTPUT -j ufw6-after-output
-A OUTPUT -j ufw6-after-logging-output
-A OUTPUT -j ufw6-reject-output
-A OUTPUT -j ufw6-track-output

Completed on Thu Dec 4 14:51:31 2014up>up>


inet6 2a01:7e00::9503:ca45:d005:d13/64 scope global temporary dynamic

Looks you have IPv6 Privacy Extentions turned on. You can confirm that with sysctl -a | grep use_tempaddr, which will show something besides 0 if you're using them.

If you have something in /etc/sysctl.d that's setting use_tempaddr to non-zero, remove that. If you don't, you can add a file there and manually set them to 0.

That fixes it. Thanks!

Why would that cause a problem?

Because your Linode can only talk to Linode's network on the IPv6 address that it owns, not weird ones it invented.

  • Les

Makes sense. Thanks again.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct